About Program

Absolute HTML Compressor 1.13, Copyright © 2000-2002 SerpikSoft

Programming and design: Michael Serpik.

Absolute HTML Compressor is freeware.
You can download the latest version of Absolute HTML Compressor from http://www.serpik.com/ahc/.

Send your questions, comments and bug reports to ahc@serpik.com.


What's New

Version 1.13:

  • Minor bugs fixed

    • Version 1.12:

  • Supports Windows XP visual styles

    • Version 1.11:

  • Improved work with tab characters

    • Version 1.1:

  • Supports command line parameters

    • Version 1.06:

  • Minor enhancements

    • Version 1.05:

  • Supports Server-Side Includes (SSI)
  • Improved style compression

    • Version 1.01:

  • Minor bugs fixed

    • Version 1.0:

  • Minor bugs fixed

    • Version 1.0 beta 1:

  • First public beta


Common Information

Absolute HTML Compressor is a powerful software that allows you to easily decrease size of HTML documents. The documents will appear in the browsers in the same way.

Absolute HTML Compressor doesn't corrupt scripts and preformatted text. It has various options that can be specified with the help of the Options dialog.


Options

The Options dialog allows you to specify different options of the optimization:

  • Merge lines.
  • Remove unnecessary whitespace characters.
  • Remove unnecessary quotation marks. For example, <table BORDER="0" CELLSPACING="0" CELLPADDING="0" align="center"> will be converted to <table BORDER=0 CELLSPACING=0 CELLPADDING=0 align=center>.
  • Replace some tags with the short ones - replace STRIKE tags with S, STRONG with B and EM with I.
  • Remove HTML comments. The comments within the scripts and styles aren't removed.
  • Remove <!DOCTYPE ...> tags.
  • Remove meta tags. You can specify names of the meta tags to remove.
  • Create backups. If this option is ON backups of the optimized files are created in a new folder.


Command Line Mode

It is possible to perform Absolute HTML Compressor commands from the command line. Common command line syntax is described below:

ahc Path -<switch1> -<switchN>

Path - the name of the folder or file to process. If the path includes spaces use quotes to delimit it.
Switches are used to define various options of the optimization. Switches entered on the command line override the same configuration settings.

You can use the following switches:

-m<Mask> - use the specified mask. If the mask includes spaces use quotes to delimit it.

The following switches are boolean ones. They define if the option is ON or OFF. If you write -s or -s+ where s is name of the switch, the appropriate option is ON. If you write -s- the appropriate option is OFF. If you don't specify the option in the command line configuration settings of the program are used.

-y | optimize without asking confirmation
-s | process subfolders
-l | merge lines
-w | remove unnecessary whitespace characters
-q | remove unnecessary quotation marks
-t | replace some tags with the short ones
-c | remove HTML comments
-d | remove <!DOCTYPE...> tags
-m | remove meta tags
-b | create backups

-a<Meta tags> - specify meta tags to remove (if -m option is ON). If the string includes spaces use quotes to delimit it.

Example:
ahc "c:\My Documents\html" -m"*.htm; *.html" -y -s- -b-


WebLog Expert

WebLog Expert is a feature rich web server log analyzer. It will give you information about your site's visitors: activity statistics, file access statistics, paths through the site, information about referring pages, search engines, browsers, operating systems, errors, and more. Flexible filters will help you perform comprehensive research. The program generates HTML-based reports with tables and charts. WebLog Expert supports log files of Apache and IIS servers and can read GZ and ZIP compressed logs. Other features include the multithreaded DNS lookup, tracked files reports, and more.

You can read more about WebLog Expert and download a full-functional 30-day trial version of the program at http://www.weblogexpert.com


HTML Search and Replace

This software allows to search and replace within multiple html documents. It is especially useful for webmasters. The search capability helps to search like in a search engine. You can use complex queries searching for words or phrases. The "+" character (word or phrase must be in documents) and "-" character (word or phrase shouldn't be in documents) may be used. Once you found a file you can view it with a built-in browser and even edit it with an editor that supports HTML syntax highlighting. Replace capability allows you to replace, insert or delete paragraphs of text within multiple documents. The program supports projects and allows to browse your html pages with a convenient explorer-like interface.

You can read more about HTML Search and Replace and download a full-functional 30-day trial version of HTML Search and Replace from http://www.serpik.com/htmlsr/


EditPro

EditPro is a professional text editor for programmers and webmasters. Allows to edit several files at a time with an unlimited size of files. Syntax highlighting for HTML, C/C++, Pascal/Delphi, Java, ASP, PHP, Perl, CSS, etc. You can create your own syntax schemes. Supports projects. You can create tools that will launch specified programs or documents (e.g. browser for the current file). Integration with command line compilers. Customizable Office 2000 and Office XP - like interface, cliptext libraries and code templates (autocomplete). Unlimited Undo/Redo, Find/Find in files/Replace with regular expression support, bookmarks, favorites, history, printing, import/export to HTML or RTF, line numbers, and more.

You can read more about EditPro and download a full-functional 30-day trial version of EditPro from http://www.serpik.com/editpro/